How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Any feedback, suggestion, bug reports, problems....
TERRABYTEONE
Posts: 3
Joined: Wed Oct 10, 2018 11:30 pm

Re: How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Post by TERRABYTEONE » Fri Oct 12, 2018 9:50 am

how do you install the file flagfox5.2.11-esr.xpi

:doh: :geek:

Advertisements

 

User avatar
DaveG
Flagfox Developer
Posts: 721
Joined: Wed Oct 03, 2007 9:06 pm
Location: Philadelphia, USA

Re: How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Post by DaveG » Sat Oct 13, 2018 4:04 am

TERRABYTEONE wrote:
Fri Oct 12, 2018 9:50 am
how do you install the file flagfox5.2.11-esr.xpi
  1. Download the last Flagfox 5.2.x ESR version from the official page: https://flagfox.wordpress.com/download#5.2
  2. Override the requirement for only Mozilla signed addons (as they no longer allow these versions posted to AMO) by following the instructions on that download page. (Firefox 52 ESR required)
  3. Install your dowloaded installer file (XPI) via the Firefox Addon Manager: Go to Firefox menu -> Add-ons -> Gear menu (next to search field) -> "Install addon from file..." (autoupdates are no longer supported for old addons, but if you upgrade to Firefox 57 or 60+, it can be updated to current versions)

relotipa
Posts: 2
Joined: Tue Mar 26, 2019 3:27 am

Re: How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Post by relotipa » Tue Mar 26, 2019 3:29 am

DaveG wrote:
Sat Oct 13, 2018 4:04 am
TERRABYTEONE wrote:
Fri Oct 12, 2018 9:50 am
how do you install the file flagfox5.2.11-esr.xpi
  1. Download the last Flagfox 5.2.x ESR version from the official page: https://flagfox.wordpress.com/download#5.2
  2. Override the requirement for only Mozilla signed addons (as they no longer allow these versions posted to AMO) by following the instructions on that download page. (Firefox 52 ESR required)
  3. Install your dowloaded installer file (XPI) via the Firefox Addon Manager: Go to Firefox menu -> Add-ons -> Gear menu (next to search field) -> "Install addon from file..." (autoupdates are no longer supported for old addons, but if you upgrade to Firefox 57 or 60+, it can be updated to current versions)
It's not working.. Is there any settings I can modify to turn this off?

click-click
Posts: 4
Joined: Sun Mar 17, 2019 2:00 pm

Re: How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Post by click-click » Tue Mar 26, 2019 12:15 pm

avada wrote:
Sun Feb 11, 2018 10:06 am

It seems more like it appears erroneously, then disappears on its own. I checked the config file and it has "{"warn.tld":"disabled","warn.stale":"disabled"}" in it. Maybe I could work around it via CSS if I could get a selector to the Flagfox specific notification.

(I forgot to mention, but I'm on Waterfrox 56.0.3)
Same here. comes and goes. I checked the storage.js file and also have

Code: Select all

{"warn.tld":"disabled","warn.stale":"disabled"}

Right now Flagfox is quiet. When the pop-ups return, I'll check the storage.js to see if something changed. The last resort will be
to edit the addon package previously mentioned in this thread.

@DaveG
Is there any way to just replace the Flagfox DB with a newer one?
Last edited by click-click on Tue Mar 26, 2019 12:50 pm, edited 2 times in total.

click-click
Posts: 4
Joined: Sun Mar 17, 2019 2:00 pm

Re: How to disable annoying notification about me using an older version? (I plan to stay on Flagfox 5.2.3)

Post by click-click » Tue Mar 26, 2019 12:40 pm

avada wrote:
Wed Feb 28, 2018 2:40 pm

Well... Since I couldn't figure out a CSS to to hide the warning I resorted to removing the warning function from flagfox.jsm. I can only do this because I can enable unsigned extensions, but at least it works.
BTW, did you just change the if (ipdb.daysOld > 90) statement to something else like if (ipdb.daysOld = 0)?

Post Reply