Warning when proxy enabled

Any feedback, suggestion, bug reports, problems....
Post Reply
meteor
Posts: 3
Joined: Fri Jul 22, 2011 3:57 am

Warning when proxy enabled

Post by meteor » Mon Jan 22, 2018 7:43 am

How can I disable this warning?
Image
I have aleady reset the network.proxy.socks_remote_dns to false. But still have the warning.
Last edited by meteor on Fri Feb 02, 2018 7:53 am, edited 1 time in total.

User avatar
DaveG
Flagfox Developer
Posts: 723
Joined: Wed Oct 03, 2007 9:06 pm
Location: Philadelphia, USA

Re: Warning when proxy enabled

Post by DaveG » Sat Jan 27, 2018 11:44 am

Unfortunately, the notifications WebExtension API I'm forced to use now is kinda not-great (also note, apparently the icon gets stretched on some platforms), and Mozilla hasn't even fully implemented it. I used to have a "Don't show this again" checkbox, but there's currently no way to add a custom checkbox/button here. I may have to write my own notification popup from scratch to add this feature back, as unfortunately is a recurring pattern when dealing with this crap API. This is not a simple thing to do, so it's lower down on the todo list, at the moment. The notifications should still only show once per session, though.

The actual setting to remember the old checkbox still exists, so technically you could manually edit the settings file (without Firefox open) and hack it in. It's just JSON, so you could add the following to the end of the file, but before the last curly brace ("}"):

Code: Select all

,"warn.proxy":"disabled"
So, your file would then be:

Code: Select all

{OTHER STUFF, "warn.proxy":"disabled"}
(note the comma; spaces around commas/colons don't matter)
The FAQ has instructions on hunting down the settings location here.

Mozilla has said that they intend to add some sort of GUI to allow people to edit WebExtension settings, similar to about:config... however, they haven't (and I don't know if they actually will, unfortunately).

meteor
Posts: 3
Joined: Fri Jul 22, 2011 3:57 am

Re: Warning when proxy enabled

Post by meteor » Fri Feb 02, 2018 8:10 am

DingTalk20180202150942.png
DingTalk20180202150942.png (423.9 KiB) Viewed 22370 times
Do you mean like this?

User avatar
DaveG
Flagfox Developer
Posts: 723
Joined: Wed Oct 03, 2007 9:06 pm
Location: Philadelphia, USA

Re: Warning when proxy enabled

Post by DaveG » Fri Feb 02, 2018 6:27 pm

meteor wrote:
Fri Feb 02, 2018 8:10 am
Do you mean like this?
Yes. Just make sure you edit and save without Firefox running to ensure it gets saved and loaded properly.

(Firefox normally saves this file as one long line, with no linebreaks or extra spacing, however it should parse fine regardless)

meteor
Posts: 3
Joined: Fri Jul 22, 2011 3:57 am

Re: Warning when proxy enabled

Post by meteor » Wed Mar 07, 2018 4:13 pm

DaveG wrote:
Fri Feb 02, 2018 6:27 pm
meteor wrote:
Fri Feb 02, 2018 8:10 am
Do you mean like this?
Yes. Just make sure you edit and save without Firefox running to ensure it gets saved and loaded properly.

(Firefox normally saves this file as one long line, with no linebreaks or extra spacing, however it should parse fine regardless)
I put a linebreak because it looks better for human.

ViceRay
Posts: 1
Joined: Tue Feb 27, 2024 11:33 pm

Re: Warning when proxy enabled

Post by ViceRay » Wed Feb 28, 2024 12:32 am

BUMP

The proxy warning has been the bane of my existence for years and years now. I must have literally closed that warning window well over 10,000 times by now. It's awful. Sometimes, it gets stuck open, and will not close until all Firefox windows are closed (i.e., all firefox.exe's are no longer running).

Unfortunately, this thread didn't help me.

I have Firefox on Windows 7 and 10. The only file I have for Flagfox is \profile\extensions\{1018e4d6-728f-4b20-ad56-37578a4de76b}.xpi. I have no idea where to put ,"warn.proxy":"disabled" or {OTHER STUFF, "warn.proxy":"disabled"}.

The user meteor (above) edited a storage.js file in \profile\browser-extension-data\{1018e4d6-728f-4b20-ad56-37578a4de76b}. I don't have this folder, so I created it, created a storage.js file, and entered into it:

Code: Select all

{
	"warn.proxy":"disabled"
}
This didn't work. :( The proxy warning window still appears.

I also have no \profile\storage\default\moz-extension+++1018e4d6-728f-4b20-ad56-37578a4de76b folder. All I have is \profile\extensions\{1018e4d6-728f-4b20-ad56-37578a4de76b}.xpi.

If anyone has any idea on how I can stop this popup from continually appearing in 2024, I would be so grateful if you could reply with specific instructions.

Post Reply